Awstat stop working after install Nginx on cpanel

Hi, here my experience with nginx and awstats on whm/cpanel.
I install nginx via command line, here the commands:

 

Nginx Admin Install instruction:

cd /usr/local/src

wget http://nginxcp.com/latest/nginxadmin.tar 

tar xf nginxadmin.tar

cd publicnginx

./nginxinstaller install 

 

Nginx Admin Uninstall instruction:

cd /usr/local/src 

wget http://nginxcp.com/latest/nginxadmin.tar 

tar xf nginxadmin.tar 

cd publicnginx

./nginxinstaller uninstall 

Then i i was able to see my nginx plugin on whm plugin. Left bar, bottom.
It works.
I have to say that i did't see a real change in server performance. My sites was quitefast due to cache configuration, and now are quite fast too. i was expecting more. But is ok.
The problem now was Awstats. Because afterr nginx installation my awstat stop any counts.
I spent many time to understand why. The problem was log.

At first i had:

  • Enable Piped Apache Logs – go to WHM -> Apache Configuration -> Piped Log Configuration -> Enable Piped Apache Logs -> Save
  •  rebuild the Nginx vhosts and restart Nginx. To do this, scroll down to: Nginx Admin
    •  Rebuild Vhosts
    •  Restart Nginx
  • When you have done all this, restart Apache / httpd service.

So i went on WHM panel, left sidebar, Server Configuration, Statistic software.
In that page you cans see all you statistic program for all your account on WHM. Here you can edit to have the user able to choose his statistic preferred log, and also download it in a text file, to analyse the log in detail.
After this edit now i have in my cpanel awstat statistic page the button UPDATE NOW, ho update in real time my awstat log. So i can see the result and keep my server nginx served.

Have a look also to Tweak Settings.

Here some articles that i find very useful to resolve the problem of Awstat stop working in Cpanel WHM, after install Nginx reverse proxy.

 

(Ok. This is my first english article. I know, i have to improve.
So, good web design to all!)